KB Archive

0

Problème de freeze lors de l’installation (ou mise à jour) d’un serveur de licence en 11.9

Lors de la mise à jour de notre serveur de licence (passage de 11.6.1 en 11.9 sur windows 2003 Fr Sp2) afin d’être compatible XenApp 6.5,  nous avons été confrontés à un freeze lors de l’installation.


Un petit tour sur citrix edocs (ici) et on nous conseille de mettre à jour notre serveur sur la partie Fix MS.


Ok mais on voudrait bien savoir quels sont les fix qu’ils nous manque. Une recherche après et nous tombons sur le trhead suivant : “11.9 License Server Installation Hangs“, et nous trouvons au passage la fameuse KB manquante “KB956572” (qui corrige un problème d’interprétation du paramètre sidtype dans la commande sc.exe).

Une fois la KB956572 installée sur le serveur et un reboot après, la mise à jour du serveur de licence est passée sans problème.


Attention à la fin de l’installation de la version 11.9 (au même titre que la version 11.6), il faut attendre que le process LSPostConfigTool.exe finisse de s’exécuter dans la cadre d’une mise à jour (éviter le reboot 🙂 ).

 

Au passage, l’inferface de gestion des licences citrix sur le site de citrix.com est vraiment plus sympa maintenant 🙂 .



Tags: ,
0

Serveur EdgeSight : Service Unavailable

Lors de la connexion http sur notre serveur Edgesight 5.3 (2003 Fr sp2) nous obtenions l’erreur “Service Unavailable.

 

Sur le serveur en question nous avons trouvé les trois events suivants dans le journal system :

Type de l’événement : Avertissement
Source de l’événement :             W3SVC
ID de l’événement :       1021
Description :
L’identité du pool d’application ‘Edgesight’ n’est pas valide. Si elle n’est toujours pas valide lors du traitement de la première requête du pool d’application, le pool d’application sera désactivé. Le champ des données contient le numéro de l’erreur.

Type de l’événement : Avertissement
Source de l’événement :             W3SVC
ID de l’événement :       1057
Description :
L’identité du pool d’application ‘Edgesight’ n’est pas valide, le service de publication sur le Web ne peut donc pas créer de processus ouvrier pour servir le pool d’application. Le pool d’application a été désactivé.

Type de l’événement : Erreur
Source de l’événement :             W3SVC
ID de l’événement :       1059
Description :
Un échec s’est produit lors de la publication du processus desservant le pool d’applications ‘Edgesight’. Le pool d’applications a été désactivé.

Après une recherche google nous sommes tombés sur la CTX126212, qui explique que le problème pourrait venir d’une installation d’ un ou plusieurs Fix MS modifiant les paramètres de sécurité ou remplacant certains fichier ASP.

La résolution préconisée par Citrix est une réparation EdgeSight afin de faire un reset des permissions ASP.

Après lecture du fichier windowsupdate.log sur le serveur EdgeSight nous avons ciblé les KB responsables :
http://support.microsoft.com/kb/2518864
http://support.microsoft.com/kb/2539631

 

Tags: , ,
0

Lenteur lors d’une installation XenApp/Presentation Server

Lors d’une installation manuelle d’un serveur XenApp, nous avons constaté une lenteur durant l’installation de XenApp (l’installation a pris plus de huit heures).

Dans notre cas, l’installation n’avançait plus à 80 % de sa progression, avec un process msiexec.exe qui ne consommait plus de cpu et semblait dans un état inerte.

Par contre si le serveur n’était pas dans le domaine (ou si vous débranchiez le câble réseau), l’installation s’exécutait normalement.

Nous vous passons les étapes de troubleshooting (Wireshark, TcpView/CurrPort, Procmon etc.. etc..)

La CTX113639 traite de ce problème, et propose de télécharger un fichier de transformation (mst) et de lancer l’installation via la ligne de commande suivante :

msiexec.exe / i "D: \ Citrix Presentation Server \ mps.msi" TRANSFORMS = "c: \ temp \ CTXUpdate.mst" / l * vc: \ temp \ mps.log

Une autre solution est possible (merci à Menhir2 et Ldap389), l’utilisation de la clé de registre “LsaLookupRestrictIsolatedNameLevel” (KB818024) qui permet avec la valeur 1, de désactiver la recherche de noms des domaines approuvés.

Le problème étant facilement reproductible, nous avons testé les deux solutions.

Les deux solutions fonctionnent très bien, cependant la solution avec la clé “LsaLookupRestrictIsolatedNameLevel”  est selon nous plus facile a mettre en place (notamment en GPO avec un ADM custom).

MAJ : 13/11/2010
Il semblerais que dans certaines circonstances, la clé LsaLookupRestrictIsolatedNameLevel c ne résolve pas le problème de slow install.
La solution d’utiliser un fichier MST lors de l’installation quand à elle fonctionne bien (CTX113639).
Merci à MAxB pour son retour 😉 .