Retour “Qfarm /load” vide…. Le retour

Nous revoilà avec un problème de commande Qfarm /Load (voir notre billet “Retour «Qfarm /load  vide“) qui ne retourne aucune charge serveur dans l’une de nos fermes (XA65 R01 US Sp1).

Comme le Qfarm /load ne retournait rien, nous sommes passés par un Get-XaServerLoad qui nous a retourné l’erreur :

 

Get-XaServerLoad : Exception has been trown by the target of an invocation

 

QfarmLoad01On comprend que l’un de nos serveurs XenApp ne répond pas correctement au Get-XaServerLoad


Afin de trouver le serveur en question on lance un  “
Get-XAserver|%{Get-XAServerLoad $_.Servername}“, Ce qui nous a permis de trouver le serveur qui ne répondait pas au Get-XAServerLoad.

On test un Qfarm /load Serveur1 (remplacez Server1 par votre serveur) qui nous répond que l’IMA n’est pas disponible (tout du moins pour cette requête)

 

QfarmLoad02


Une fois sur le serveur en question nous rencontrons l’event Event ID 3609
“Failed to load plugin C:\Program Files (x86)\Citrix\System32\Citrix\IMA\SubSystems\ImaAppSs.dll with error IMA_RESULT_WRITE_TO_LOG_FAILED” qui nous amène à la CTX134504.

La lecture de la  CTX134504 met en évidence que le problème vient du CitrixLogServer COM+ qui ne repond pas.

Du coup direction le Service des composants (comexp.msc), en développant Console Root-Component Services-Computer-COM+Application nous tombons sur l’erreur :


An error occurred while processing the last operation. Error code 8007042C – The dependency service or group failed to start

 

QfarmLoad03Ok ça risque pas de fonctionner la 🙂

 

En regardant les dépendances du Service Application système COM+ ( COM+ System Application) nous constatons que le service Système d’événement COM+ (System Event Notification Service ) était désactivé. Une fois le service service Système d’événement COM+ activé et démarré le Qfarm /load retournait bien les valeurs de charge de tous les serveurs membre de la ferme.

WTF

About ctxblog