Erreur : [com.citrix.xml.NFuseProtocol.RequestAppData] sur WI 5.3

Vues : 0

Lors d’un troubleshooting avec Menhir Two sur des problèmes d’accès à nos WI, nous sommes tombé sur l’event suivant sur une de nos Web Interface :

ID de l’événement : 30110
Une erreur de type IMA avec un ID d’erreur 0x80000001 a été signalée par le service XML Citrix à l’adresse http://ServeurWi/Site/scripts/wpnbr.dll [com.citrix.xml.NFuseProtocol.RequestAppData]. En fonction du serveur exécutant le service XML, de plus amples informations sont disponibles dans le journal des événements du serveur. La transaction de ce service XML Citrix a échoué, mais le service XML n’a pas été supprimé de la liste des services actifs. [ID de journal unique : ad65cd59]

 

Suivi de l’event 31003 :

ID de l’événement : 31003
Description :Chemin d’accès au site : c:\inetpub\wwwroot\SiteWi.
Aucun des services XML Citrix configurés pour la batterie VotreBatterie n’ont répondu à cette transaction de service XML. [ID de journal unique : 8f5a64b8]

Puis revient l’event 30110 :

ID de l’événement : 30110
Description :Chemin d’accès au site : c:\inetpub\wwwroot\VotreSiteWi.
Une erreur de type IMA avec un ID d’erreur 0x80000001 a été signalée par le service XML Citrix à l’adresse http://ServeurXml:Port/scripts/wpnbr.dll [com.citrix.xml.NFuseProtocol.RequestValidateCredentials]. En fonction du serveur exécutant le service XML, de plus amples informations sont disponibles dans le journal des événements du serveur. La transaction de ce service XML Citrix a échoué, mais le service XML n’a pas été supprimé de la liste des services actifs. [ID de journal unique : 8c20c93a]


Le RequestValidateCredentials est explicite, donc direction nos Xml Broker 🙂 .

Sur un de nos Xml Broker nous retrouvons bien une erreur dans le journal de sécurité  (event 4625).

ID de sécurité :                 SERVICE RÉSEAU
Nom du compte :                         XMLBROKER$
Domaine du compte :                   DOMAINE
ID d’ouverture de session :                        0x3e4
Type d’ouverture de session :                                  3
Compte pour lequel l’ouverture de session a échoué :
ID de sécurité :                 NULL SID
Nom du compte :                           Le compte Utilisateur ne pouvant pas s’authentifier
Domaine du compte :                   DOMAINE
Informations sur l’échec :
Raison de l’échec :                         L’utilisateur n’est pas autorisé à ouvrir une session sur cet ordinateur.

Avec la raison de l’échec nous avons une piste, un petit tour sur une DSA.msc, et une petite recherche sur l’objet utilisateur causant problème.

Effectivement notre user ne risquait pas de s’authentifier sur nos XML Broker 🙂

il nous reste a communiquer aux admins qu’on évite ce genre de restriction dans notre environnement sinon ldap389 va pas être content 😉 .

 

Post to Twitter

4 réflexions sur « Erreur : [com.citrix.xml.NFuseProtocol.RequestAppData] sur WI 5.3 »

  1. Salut,

    Pour information, le même comportement peut être lié à une modification faite au niveau de l’attribution des droits utilisateurs via les stratégies Local. En effet sous Windows 2003 / XenApp 5, il faut avoir le droit “Allow log on locally” pour les utilisateurs.

    Pour contourner le problème, il existe un contournement chez Citrix :
    For Access this Computer from the Network Policy

    Open the registry editor (regedit)
    Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\IMA or HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432node\Citrix\IMA on 64bit servers.
    Create a DWORD value UseNetworkLogon with value data =1.
    Restart the IMA service.
    Add the users to access this computer from the network policy.
    Source : http://support.citrix.com/article/CTX131115/

    Pour information, c’est le comportement par défaut d’une installation XenApp 6.5 (on voit bien les logon types 3 arriver sur le broker XML alors que l’on a des 2 sur un XenApp 5…

    En espérant que cela puisse aider…
    Sam

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*