Horizon Archive

0

Horizon 7.10 error : warning Echec de la connexion

Suite à la migration d’un environnement Horizon view 7.3 vers 7.10, on nous a remonté une erreur de connexion à la console d’administration HTML5 avec les navigateurs Chrome (79.0.3945.117 – Build officiel – 32 bits ) et Firefox (72.0.1 – 32 bits).

 

Le problème se produit uniquement avec Chrome et Firefox… qui a dit que Internet Explorer était un mauvais navigateur 🙂 .

 

Ce problème de connection peut-être résolu en modificant le fichier “locked.properties” (dans le cadre d’un problème d’affichage HTML5 via le navigateur Edge et en passant par des F5 nous avions deja eu l’occasion de jouer avec le fichier “locked.properties”). Revennons à nos moutons, la KB2144768 chez VMware nous donne la liste des actions à réaliser afin résoudre ce problème de connexion.

  1. Créer le fichier C:\Program Files\VMware\VMware View\Server\sslgateway\conf\ locked.properties
  2. Ajouter la ligne : checkOrigin=false
  3. Redémarrer le service « Composant VMware Horizon View Security Gateway” (wstunnel)

 

Voila ça c’est fait (il nous reste encore quelques bugs qui feront l’objet d’autres posts 🙂 )
0

Horizon View 7.8 : vmware view error during provisioning initial publish failed fault type is VC_FAULT_FATAL

Lors de l’intégration d’un serveur composer dans une infra  Horizon View 7.8 on nous a remonté l’erreur ci-dessous lors du déploiement de machines au sein d’un pool de postes de travail en “Automated, instant clone, floating”.

 

vmware view error during provisioning initial publish failed fault type is VC_FAULT_FATAL

 

Au départ nous pensions à un problème de permissions sur le Vcenter, mais en regardant de plus près sur la configuration du vCenter/Composer dans la console “Horizon 7 Administrator” nous avons constaté que le vCenter était configuré avec un compte local

 

Et si on configurait l’accès au vCenter avec un compte de service du domaine 🙂

 

Une fois le compte local remplacé par un compte de service du domaine (avec les permissions adéquates) le déploiement de machines a pu se faire sans problème.

 

Nous avons mis le même compte de service pour le vCenter et le Composer 😉