XA 6.5 : sessions déconnectées

Récemment on nous a remonté un problème de sessions déconnectées sur des serveurs XA 6.5 R06 US, en regardant sur l’AppCenter de la ferme en question on constate bien les sessions déconnectées.

 

02Une série de sessions déconnectées, observer l’heure du logon (ça donne direct une bonne info)

 

En regardant sur un des serveurs nous avons remarqué que les sessions déconnectées n’étaient pas présentes dans le gestionnaire de tâches et pas d’event côté eventlog)

 

03La bonne nouvelle c’est que tout le monde n’est pas impacté

 

Dans un premier temps nous avons pensé à une fuite mémoire (à tort), et dans pareil cas rien ne vaut un RAMMap.

 

04Ok là tout devient plus clair, toutes les sessions déconnectées ont trois process de lancés (LogonUI.exe, Winlogon.exe et crss.exe.exe)

 

Direction Process Explorer afin d’en savoir plus, en observant un process Winlogon.exe d’une session déconnectée nous avons remarqué via l’onglet Thread que la Dll twi3.dll avait un statut « Wait:UserRequest ».

 

05On touche au but la

 

Un coup de google plus loin nous tombons sur la CTX138197, le point 7 nous explique la cause du problème :
 

Sessions running on single-monitor, aero-enabled Windows client devices can disconnect unexpectedly. The issue can occur when a preview, as part of the Dynamic Window Preview feature, is sent to the client; at that time, a twi3.dll thread can terminate the Winlogon.exe process, which in turn causes the session to disconnect.
To resolve this issue in its entirety, you must install both a XenApp and a Receiver hotfix that contains Fix #LA2858.

 
Après une mise à jour des clients receiver (ils étaient en 3.4) le problème n’est plus réapparu.

 

 

 

About ctxblog